1.路由器基本配置命令
(1)路由器显示命令
router#show run;显示配置信息
router#show interface;显示接口信息
router#show ip route;显示路由信息
router#show cdp neighbor;显示邻居信息
router#reload;重新启动
(2)路由器口令设置
router>enable;进入特权模式
router#config terminal;进入全局配置模式
router(config)#hostname XX;设置路由器的主机名
router(config)#enable secretxxx;设置特权加密口令
router(config)#enable passwordxxx;设置特权非密口令
router(config)#line console0;进入控制台口
router(config-line)#linevty 04;进入虚拟终端
router(config-line)#login;要求口令验证
router(config-line)#password xx;设置登录口令xx
router(config)#(Ctrl+z);返回特权模式
router#exit;返回命令
(3)路由器接口配置
router(config)#interface s0/0;进入Serail接口
router(config-if)#no shutdown;激活当前接口
router(config-if)#clock rate 64000;设置同步时钟
router(config-if)#ip address XX;设置IP地址
router(config-if)#ipaddress second XX;设置第二个IP
router(config-if)#interface f0/0.1;进入子接口
router(config-subif.1)#ip address XX;设置子接口IP
router(config-subif.1)#encapsulation dot1q;绑定vlan中继协议
router(config)#config-register 0x2142;跳过配置文件
router(config)#config-register 0x2102;正常使用配置文件
router#reload;重新引导
(4)路由器文件操作
router#copy running-config startup-config;保存配置
router#copy running-config tftp;保存配置到tftp
router#copy startup-config tftp;开机配置保存到tftp
router#copy tftp flash:;下传文件到flash
router#copy tftp startup-config;下载配置文件
(5)静态路由
router(config)#ip route2.0.0.0 255.0.0.01.1.1.2;静态路由举例
router(config)#ip route0.0.0.0 0.0.0.01.1.1.2;默认路由举例
(6)动态路由
router(config)#ip routing;启动路由转发
router(config)#router rip;启动RIP路由协议。
router(config-router)#network XX;设置发布路由
router(config-router)#negihbor;点对点帧中继用。
(7)帧中继命令
router(config)#frame-relay switching;使能帧中继交换
router(config-s0)#encapsulation frame-relay;使能帧中继
router(config-s0)#fram-relaylmi-type cisco;设置管理类型
router(config-s0)#frame-relayintf-type DCE;设置为DCE
router(config-s0)#frame-relaydlci16;
router(config-s0)#frame-relay local-dlci20;设置虚电路号
router(config-s0)#frame-relay interface-dlci16;
router(config)#log-adjacency-changes;记录邻接变化
router(config)#ints0/0.1 point-to-point;设置子接口点对点
router#show frame pvc;显示永久虚电路
router#show frame map;显示映射
(8)基本访问控制列表
router(config)#access-list permit|deny
router(config)#interface;default:deny any
router(config-if)#ip access-group in|out;defaultut
(9)路由器NAT配置(www.xing528.com)
Router(config-if)#ip nat inside;当前接口指定为内部接口
Router(config-if)#ip nat outside;当前接口指定为外部接口
Router(config)#ip nat inside source static[p][port]
Router(config)#ip nat inside sources tatic 10.65.1.260.1.1.1
Router(config)#ip nat inside source statictcp 10.65.1.38060.1.1.180
Router(config)#ip nat pool p1 60.1.1.160.1.1.20255.255.255.0
Router(config)#ip nat inside source list 1 pool p1
Router(config)#ip nat inside destination list 2 pool p2
Router(config)#ip nat inside source list 2 interface s0/0 overload
Router(config)#ip nat pool p2 10.65.1.210.65.1.4255.255.255.0type rotary
Router#show ip nat translation
rotary参数是轮流的意思,地址池中的IP轮流与NAT分配的地址匹配。
overload参数用于PAT将内部IP映射到一个公网IP不同的端口上。
(10)外部网关协议配置
router(config)#router bgp 100
router(config-router)#network19.0.0.0
router(config-router)#neighbor8.1.1.2remote-as 200
(11)配置PPP验证
Router(config)#username password
Router(config)#int s0
Router(config-if)#ppp authentication{chap|pap}
2.路由协议配置
(1)静态路由的配置
通过配置静态路由,用户可以人为地指定对某一网络访问时所要经过的路径,在网络结构比较简单,且一般到达某一网络所经过的路径唯一的情况下采用静态路由。其具体配置格式如下。
其中,
●network:指所要到达的目标网络(未知网络)的网络号。
●mask:是子网掩码。
●address:指达到该目标网络的下一个广域网端口地址(下一跳地址),即访问路径中相邻路由器的广域网端口地址。
●interface:本地网络接口名称。
●distance:管理距离,默认值为1或0,是一个可选参数。
●permanent:指定此路由即使该端口关掉也不被删除,是一个可选参数。
(2)动态路由的配置
在路由器上启用RIP路由协议的命令如下。
routerrip 声明使用RIP协议
network network-number指定与该路由器相连的网络,即发布路由器所直接连接的网段
(3)修改RIP协议,使用IGRP协议
no router rip 取消RIP协议
routerigrp 100 使用IGRP协议,其中的100是自治域系统(AS)号
network network-number指定与该路由器相连的网络
(4)使用OSPF协议
routerospf100 使用OSPF协议,其中100为路由进程process-id号
Network address wildcard-mask area area-id
其中,address可以为连接路由器的网络、子网或接口IP地址;而wildcard-mask为通配符子网掩码,它指定在判断IP地址是否匹配时需要考虑哪部分,0表示相应位必须匹配,1表示不考虑,如,0.0.0.0表示全部32位都必须匹配;相应的area-id指要将地址加入到哪个区域,如0表示骨干区域)。
(5)查看路由协议
show ip route
show ip protocol
3.路由器访问控制(ACL)配置
访问控制列表主要包括标准访问列表和扩展访问列表两种类型。标准ACL只检查分组的源地址;扩展ACL既检查分组的源地址,也检查分组的目的地址,也可以检查特殊的协议类型、端口及其他参数。
(1)标准访问控制
全局配置命令access-list用于创建访问列表。
access-list access-list-number{permit|deny}source[source-wildcard]
其中,access-list-number是ACL的列表号,标准IP ACL列表号范围为1~99;permit|deny指定允许还是禁止来自指定地址的数据流通过;而source表示源IP地址,source-wild-card表示源IP地址的通配符掩码(反掩码)。
接口配置命令ip access-group用于在接口上激活以上所建IP访问列表。
ip access-group access-list-number{in|out}
其中,in|out是针对本路由器数据包的进出传输方向,如没指定是in或是out,则默认是out(出方向)。
在访问列表的最后面都有一条隐式语句denyany。当仅输入一条permit语句后,访问列表将会从允许所有数据流通过变成禁止大部分数据流通过,从而实现只允许特定的(permit语句所定义的网络或节点)网络数据流通过;相反,在定义禁止(denyX.X.X.X)特定的网络或节点之后,都得加上Access-list access-list-number permitany,定义除禁止特定网络或节点之外的网络或节点能通过并到达相应网络。下扩展访问列表亦然。
(2)扩展访问控制
全局配置命令access-list用于创建访问列表。
其中,access-list-number是ACL的列表号,扩展IPACL列表号范围是100~199;permit|deny指定该条目是允许还是禁止符合指定条件的数据流通过;protocol可以是IP、TCP、UDP、ICMP等协议;source及destination指定源IP及目标IP地址;source-wildcard、destina-tion-wildcard是通配符掩码;operator可为1t(小于)、gt(大于)、eq(等于)或neq(不等于),port为协议端口号。
接口配置命令ip access-group用于在接口上激活以上所建IP访问列表。
其中,in|out是针对本路由器数据包的进出传输方向,如没指定是in或是out,则默认是out(出方向)。在每个接口的每个方向上,每种协议只能有一个访问列表。
免责声明:以上内容源自网络,版权归原作者所有,如有侵犯您的原创版权请告知,我们将尽快删除相关内容。